TURNIER-AKTUELL Release Notes

TURNIER-AKTUELL

Version 3.78-017

Release Notes

Dieses Dokument enthält urheberrechtlich geschützte Informationen. Alle Rechte vorbehalten. Ohne die vorherige schriftliche Genehmigung des Copyright-Inhabers darf kein Teil dieser Dokumentation in irgendeiner Form durch Fotokopie, Mikrofilm oder andere Verfahren reproduziert oder in eine für elektronische Systeme verwendbare Sprache übertragen werden. Auch die Rechte der Wiedergabe durch Vortrag, Funk und Fernsehen sind vorbehalten.

Änderungen an der Dokumentation und der darin beschriebenen Produkte ohne vorherige Bekanntmachung bleiben vorbehalten.

Bei der Zusammenstellung von Texten und Abbildungen wurde mit größter Sorgfalt vorgegangen. Wir können jedoch für eventuell verbliebene technische oder typografische Fehler und deren Folgen weder eine juristische Verantwortung noch irgendeine Haftung übernehmen. Für Verbesserungsvorschläge und Hinweise auf Fehler sind wir jedoch stets dankbar.

Wir gewährleisten nicht, dass Änderungen an Software und Hardware anderer Hersteller, auf die in diesem Handbuch Bezug genommen wird, ohne Auswirkungen auf die Anwendbarkeit der in dem Handbuch enthaltenen Informationen bleiben.

Die in diesem Handbuch beschriebene Software wird unter einer Lizenzvereinbarung bereitgestellt. Die Benutzung und Vervielfältigung des Programms erfolgt ausschließlich aufgrund dieser Lizenzbestimmungen, die dem Produkt beiliegen.

Die Informationen in diesem Handbuch werden ohne Rücksicht auf einen eventuellen Patentschutz veröffentlicht. Warennamen werden ohne Gewährleistung der freien Verwendbarkeit benutzt. Die in den Beispielen verwendeten Namen und Daten sind frei erfunden, soweit nichts anderes angegeben ist. Jede Ähnlichkeit mit tatsächlichen Firmen, Personen, Namen oder Daten ist rein zufällig.

Copyright © Karlheinz Faltermann – Alle Rechte vorbehalten.


Release Notes

Dieses Dokument enthält Hinweise und Beschreibungen von Problemen und Restriktionen sowie Korrekturen und Ergänzungen zur aktuellen Softwareversion und Dokumentation. Die nachfolgenden Informationen beziehen sich auf die Version 3.78-017 und ersetzen die Release Notes älterer Softwareversionen.

Sollte die Dokumentation nicht alle eventuell auftretenden Fragen beantworten, oder haben Sie Verbesserungsvorschläge zu TURNIER-AKTUELL, so könnte der direkte Kontakt zum Entwickler eventuell weiterhelfen. Näheres zum persönlichen Kundenservice erfahren Sie unter „Support“.

Weitere Informationen zu TURNIER-AKTUELL finden Sie auf unserer Produkthomepage www.turnier-aktuell.de.


Dokumentation

Aktuelle Hinweise zur Dokumentation:

  • Das vorliegende Handbuch ersetzt die Release Notes der Version 3.78-010.

  • Die Handbücher für Turnierplanung, Turnierleitung und Turnier-Informationsdienst basieren auf der Version 3.78-010 vom Mai 2016. Textbeschreibungen und Abbildungen können wegen Softwarekorrekturen oder Erweiterungen von der vorliegenden Version abweichen.

  • Alle Beschreibungen und Hinweise zur Softwarekomponente Turnier-Informationsdienst betreffen nur die Vollversion und sind in der Light Edition nicht relevant.


Programm Turnierplanung

Programmkorrekturen/Verbesserungen in Version 3.78-017

Optimierte Datenzugriffe

Das Lesen und insbesondere das Schreiben der Daten wurde gegenüber der Version 3.78-010 erheblich beschleunigt.

Längenprüfung des Turniertitels

Der Turniertitel darf maximal 32 Zeichen lang sein. In der Vergangenheit wurde die Länge nicht geprüft. Das hatte zur Folge, dass bei zu langem Turniertitel ein gespeichertes Turnier nachträglich nicht mehr bearbeitet werden konnte. Seit Version 3.78-015 wird die Länge des Turniertitels geprüft.

Programmkorrekturen/Verbesserungen in Versbio 3.78-010

Kompatibel zu Java Version 8

In der aktuellen Version ist das Programm Turnierplanung kompatibel zu Java Version 8.

Unabhängigkeit von Windows 32- und 64-Bit-Systemen

Die aktuelle Version läuft sowohl mit Java Runtime für 32- als auch für 64-Bit-Windows-Systeme.

Erneuter Programmstart

Das Erkennen, ob das Programm Turnierplanung bereits gestartet ist, wurde verbessert. Die Abfrage, ob das Programm trotzdem gestartet werden soll, ist nicht mehr nötig.

Systemparameter

Geänderter Systemparameter EDIT_SPIELERGEBNIS

Bei neuen Turnierplänen ist der Systemparameter EDIT_SPIELERGEBNIS jetzt so eingestellt, dass Zwischenstände und Endergebnisse im Programm Turnierleitung numerisch (z. B. 3:1) erfasst werden. Bisher war voreingestellt, dass die Tore nur über die Schaltflächen [+] neben den Mannschaftsnamen in der Übersicht Aktuelle Spiele einzeln erfasst werden konnten.

Neuer Systemparameter ZEITTAFEL_AKTIV

Mit diesem Systemparameter lässt sich die Steuerung der TID-Zeittafel durch das Programm Turnierleitung generell ein- und ausschalten.

Neuer Systemparameter SPIELENDE_AUTO

Dieser Systemparameter steuert das Verhalten des Programms Turnierleitung bei Spielende. Ist das Häkchen gesetzt, werden Spiele nach Ablauf der Spielzeit automatisch beendet. Ist das Häkchen nicht gesetzt, muss das Spiel per Mausklick beendet werden.

Voreinstellung der Berechnungsregeln für Gruppenspiele

Der direkte Vergleich ist bei den Berechnungsregeln für Gruppenspiele jetzt voreingestellt. Die Reihenfolge der Berechnungsregeln entspricht den heutigen Regeln der CL-Gruppenphase.

Spieletreffs mit ungerader Mannschaftszahl

Bei Spieletreffs mit ungerader Mannschaftszahl wurden für einige Mannschaften zu wenig Spiele eingeplant. Dieses Problem wurde in der aktuellen Version behoben.

Bekannte Probleme und Restriktionen

Nutzung der Gesamtplatzierung in älteren Turnierplänen

Um die neue Funktion zur Berechnung der Gesamtplatzierung nutzen zu können, müssen Sie Turnierpläne, die mit TURNIER-AKTUELL Version 1 oder 2 erstellt wurden, mit dem Programm Turnierplanung nochmals öffnen und neu speichern.

Spiele über Tagesgrenzen

Wenn Sie Turniere über Mitternacht planen, so werden im Dialogfenster „Zeitplanung“ Spiele falsch geplant, die vor Mitternacht beginnen und erst nach Mitternacht enden.

Sie können sich behelfen, indem Sie den Start des Turniers über das Dialogfenster „Grundeinstellung“ zeitlich vorverlegen, damit das Tagesende vor 24:00 Uhr liegt. Dann können Sie Ihre manuellen Planänderungen im Fenster „Zeitplanung“ vornehmen und danach den Turnierstart wieder zurücksetzen.

Prüfung der Turnierzeiten

Sämtliche Zeitangaben in den Grundeinstellungen und Kategorie-Einstellungen sind nur Randbedingungen bei der zeitlichen Planung des Turniers.

Es ist also durchaus möglich, dass das Programm Spiele auf einen Termin legt, der nicht dem vorgegebenen Zeitrahmen entspricht.

Ebenso können Sie im Dialogfenster „Zeitplanung“ Spiele außerhalb des Zeitfensters dieser Kategorie planen.

Erst beim Speichern des Zeitplans werden die Spieltermine überprüft und Planungsfehler entfernt.

Um vorab festzustellen, ob Ihr Turnierplan keine der vorgegebenen Zeitregeln verletzt, müssen Sie die Schaltfläche [PLAN PRÜFEN] im Dialogfenster „Zeitplanung“ anklicken.

Vorsicht beim Umbenennen der Gruppen

Die Gruppennamen können im Dialogfenster „Spielplanung“ geändert werden. Gleichzeitig werden auch die Mannschaftstexte für die Qualifizierung zur nächsten Spielrunde (z. B. „Platz 1 Gruppe 1 Vorrunde“) angepasst. Diese Namensänderungen werden in der aktuellen Version auf Basis einfacher Textvergleiche ausgeführt. Wenn beispielsweise die Gruppe 1 in Gruppe A geändert wird, werden auch die zugehörigen Mannschaftstexte geändert: Aus „Platz 1 Gruppe 1 ...“ wird dann logischerweise „Platz 1 Gruppe A ...“.

Diese Textänderungen funktionieren aber nur, wenn die auszutauschenden Textfragmente auch eindeutig identifiziert werden können. In einem konkreten Fall waren 10 Gruppen mit den Namen „Gruppe 1“ bis „Gruppe 10“ vorgegeben. Das Ändern der Gruppe 1 in Gruppe A führte dazu, dass gleichzeitig die zur Gruppe 10 gehörenden Mannschaftstexte ebenfalls geändert wurden, und zwar von „Platz 1 Gruppe 10 Vorrunde“ in „Platz 1 Gruppe A0 Vorrunde“.

Hätte der Anwender zuerst die „Gruppe 10“ in „Gruppe J“ umgetauft, hätte er das Problem umgehen können.

Keine Reaktion bei numerischen Eingabefeldern?

Numerische Eingabefelder erlauben nur Ziffern und eventuell das Dezimal-Trennzeichen. Wenn keine Eingaben möglich sind, dann liegt es meist daran, dass Sie die Feststelltaste (engl. Caps Lock) gedrückt haben. Dadurch werden die über den Ziffern abgebildeten Sonderzeichen, beispielsweise das Dollarzeichen ($) über der Ziffer 4, eingegeben. Das Programm verwirft solche Eingaben. Für den Anwender sieht es so aus, als würde das Programm nicht mehr reagieren.

Sicherungskopien der Datenbanken

Bei jedem Öffnen- oder Speichervorgang wird automatisch eine Komprimierung der Turnierdateien ausgeführt. Dabei entstehen Sicherungskopien („*.*_bak“). Sollte die Komprimierung, aus welchem Grund auch immer, fehlschlagen, können Sie auf diese Sicherungskopie zurückgreifen, indem Sie die Endung „.bak“ im Dateinamen entfernen. Die Sicherungskopien können am Ende der Turnierplanung auf der Festplatte gelöscht werden.

Keine Unterstützung für „Silver Goal“

In der aktuellen Programmversion wird die neue Regelung „Silver Goal“ bei Verlängerungen noch nicht berücksichtigt.


Programm Turnierleitung

Programmkorrekturen/Verbesserungen in Version 3.78-017

Optimierte Datenzugriffe

Das Lesen und insbesondere das Schreiben der Daten wurde gegenüber der Version 3.78-010 erheblich beschleunigt. Der Fehler beim Speichern der Tordaten - aufgetreten in Version 3.78-010 - ist behoben.

Verbessertes Hauptfenster

Der Bildaufbau des Hauptfensters wurde korrigiert. Beim Vergrößern des Hauptfensters wird jetzt die Spieleübersicht in gleichem Maße größer.

Korrigierte Berechnung der Qualifikanten

Wurde eine Hoffnungsrunde geplant, so wurden die Qualifikanten trotzdem nur für eine Spielrunde berechnet. Für die zweite Spielrunde blieb die Berechnung aus. Dieser Fehler wurde in Version 3.78-016 behoben.

Korrigierte Anzeige in der Spieleübersicht

Nach Bestätigung der Qualifikanten wurden in der Spieleübersicht nicht immer alle Teilnehmer der nächsten Spielrunden aktualisiert. Dieses Problem wurde jetzt behoben.

Fehlmeldungen an TID-Audio

Unter bestimmten Umständen wurden Ereignisse an TID-Audio mehrfach gemeldet, was dann zu ungeplanten Audio-Einspielungen führte. Dieses Problem war seit Version 3.78 vorhanden und wurde jetzt behoben.

Programmkorrekturen/Verbesserungen in Version 3.78-010

Kompatibel zu Java Version 8

In der aktuellen Version ist das Programm Turnierleitung kompatibel zu Java Version 8.

Unabhängigkeit von Windows 32- und 64-Bit-Systemen

Die aktuelle Version läuft sowohl mit Java Runtime für 32- als auch für 64-Bit-Windows-Systeme.

Erneuter Programmstart

Das Erkennen, ob das Programm Turnierleitung bereits gestartet ist, wurde verbessert. Die Abfrage, ob das Programm trotzdem gestartet werden soll, ist nicht mehr nötig.

Systemparameter

Geänderter Systemparameter EDIT_SPIELERGEBNIS

Bei neuen Turnierplänen ist der Systemparameter EDIT_SPIELERGEBNIS jetzt so eingestellt, dass Zwischenstände und Endergebnisse numerisch (z. B. 3:1) erfasst werden. Bisher war voreingestellt, dass die Tore nur über die Schaltflächen [+] neben den Mannschaftsnamen in der Übersicht Aktuelle Spiele einzeln erfasst werden konnten.

Neuer Systemparameter ZEITTAFEL_AKTIV

Mit diesem Systemparameter lässt sich die Steuerung der TID-Zeittafel durch das Programm Turnierleitung generell ein- und ausschalten.

Neuer Systemparameter SPIELENDE_AUTO

Dieser Systemparameter steuert das Verhalten des Programms Turnierleitung bei Spielende. Ist das Häkchen gesetzt, werden Spiele nach Ablauf der Spielzeit automatisch beendet. Ist das Häkchen nicht gesetzt, muss das Spiel per Mausklick beendet werden.

Überprüfung der Qualifikationsregeln

In seltenen Fällen wurden die Qualifikationsregeln nach Spielrunden-Änderungen nicht neu berechnet. Die Überprüfung und Neuberechnung der Qualifikationsregeln wurden in dieser Version verbessert.

Reaktivieren vorheriger Spielrunden

Um Korrekturen an vorherigen Spielrunden vornehmen zu können, mussten diese reaktiviert werden. Als Voraussetzung mussten alle Spiele der aktuellen Spielrunde neu angesetzt werden. Trotzdem war es danach nicht immer möglich, die vorherige Spielrunde zu reaktivieren. Insbesondere gab es Probleme, wenn beide Spielrunden derselben Platzierungsgruppe angehörten oder wenn parallele Spielrunden geplant waren. Das Verhalten beim Reaktivieren von Spielrunden wurde geprüft und korrigiert.

Bekannte Probleme und Restriktionen

Keine Nutzung der Gesamtplatzierung in älteren Turnierdateien

Bei Turnierdateien, die mit dem Programm Turnierleitung Version 1 oder 2 gespeichert wurden, fehlen die Regeln zur Berechnung der Endplatzierung. Somit ist eine nachträgliche Berechnung der Gesamtplatzierung nicht möglich.

Spiele über Tagesgrenzen

Turniere über Mitternacht können unter Umständen über das Dialogfenster „Planänderung“ nicht umgeplant werden. Der beim Programm Turnierplanung vorgeschlagene Work-around kann hier nicht angewendet werden.

Keine Berücksichtigung der „Golden Goal“- und „Silver Goal“-Regeln

Bei der Option „Golden Goal“ im Dialogfenster Einstellungen ist anzunehmen, dass ein in der Verlängerung befindliches Spiel automatisch beendet wird, sobald ein Tor registriert wird. Das ist in der aktuellen Programmversion nicht so. Das Spiel muss vom Anwender gestoppt werden.

Die neue Regelung „Silver Goal“ wird von der aktuellen Programmversion ebenfalls nicht unterstützt.

Keine Reaktion bei numerischen Eingabefeldern?

Numerische Eingabefelder erlauben nur Ziffern und eventuell das Dezimal-Trennzeichen. Wenn keine Eingaben möglich sind, dann liegt es meist daran, dass Sie die Feststelltaste (engl. Caps Lock) gedrückt haben. Dadurch werden die über den Ziffern abgebildeten Sonderzeichen, beispielsweise das Dollarzeichen ($) über der Ziffer 4, eingegeben. Das Programm verwirft solche Eingaben. Für den Anwender sieht es so aus, als würde das Programm nicht mehr reagieren.

Sicherungskopien der Datenbanken

Bei jedem Öffnen- oder Speichervorgang wird automatisch eine Komprimierung der Turnierdateien ausgeführt. Dabei entstehen Sicherungskopien („*.*_bak“). Sollte die Komprimierung, aus welchem Grund auch immer, fehlschlagen, können Sie auf diese Sicherungskopie zurückgreifen, indem Sie die Endung „.bak“ im Dateinamen entfernen. Die Sicherungskopien können am Ende des Turniers auf der Festplatte gelöscht werden.


Der Turnier-Informationsdienst

Der Turnier-Informationsdienst ist Bestandteil der Vollversion. Im Lieferumfang der Light Edition ist dieses Modul nicht enthalten.

Programmkorrekturen/Verbesserungen

Neues Programm TID-Zeittafel

Mit Version 3.78 wird das Programm TID-Zeittafel ausgeliefert. Dieses Programm bildet eine Anzeigetafel nach. Es zeigt die Mannschaften, den aktuellen Spielstand und die Spielzeit.

Neue Anzeigebereiche in der TID-Anzeige

Der Mittelteil kann jetzt von einem linken und einem rechten Rand flankiert werden. Die Randbereiche dienen der Anzeige von statischen Seiten. Über die TID-Konfiguration ist außerdem einstellbar, ob die statischen (Werbe-)Seiten nur im Mittelbereich angezeigt werden oder auch den linken und rechten Randbereich überdecken.

Größeneinstellung für die TID-Anzeige

Im Programm TID-Konfiguration können die Anzeighöhe von Kopf- und Fußteil und die Breiten des linken und rechten Randbereichs angegeben werden. Die Angaben sind Prozentangaben relativ zur Bildschirmgröße.

Wahl der Tabellenanzeige

Über das Programm TID-Konfiguration kann zwischen der Anzeige einer Standardtabelle oder einer Kreuztabelle gewählt werden.

Nächster Spieltermin

Neue Funktion in der TID-Anzeige: Der nächste Spieltermin der Mannschaften kann angezeigt werden.

Geschwindigkeit der Laufschriftmeldung

Die Geschwindigkeit der Laufschrift lässt sich im Programm TID-Konfiguration einstellen.

Neue Voreinstellung für die TID-Anzeige

Die Voreinstellungen wurden für hochauflösende Monitore optimiert:

  • Der Anzeigemodus wurde auf kompakt geändert.
  • Der Gruppenspielplan wurde auf die Anzeige als Gesamtspielplan umgestellt.
  • Der Mittelteil ist zur Anzeige von 20 Zeilen vergrößert worden.
  • Als Tabellenform wurde die neue Kreuztabelle ausgewählt.

Bekannte Probleme und Restriktionen

Programm TID-Anzeige: Dialogfenster TID-Anzeige

Das Dialogfenster TID-Anzeige kann nicht geöffnet werden, wenn gerade ein Videofilm abgespielt wird.

Programm TID-Konfiguration: keine Anzeige der aktuellen Meldung

Sie können eine Hinweismeldung anzeigen, die in Laufschrift im Fußteil des Turnier-Informationsdienstes geschrieben wird. Und zwar so lange, bis Sie die Meldung wieder entfernen.

Der Meldungstext wird im Registerblatt Meldung des Programms TID-Konfiguration erfasst. Wenn Sie das Programm danach beenden und später neu starten, wird der aktuelle Meldungstext im Registerblatt Meldung nicht mehr angezeigt. Das Programm vergisst also den aktuellen Meldungstext. Trotzdem können Sie die Laufschriftmeldung über das Programm abschalten.

Die Laufschriftanzeige im Turnier-Informationsdienst wird davon nicht beeinflusst.


Support

Sollten Sie Fragen oder Probleme mit der Anwendung haben, können Sie sich über folgende Adressen direkt an den Entwickler wenden:

  • per E-Mail:
    Schicken Sie Ihre Anfrage oder Problemschilderung an info@turnier-aktuell.de.

  • per Post an
    Karlheinz Faltermann
    Joseph-Haydn-Straße 7
    68519 Viernheim

Geben Sie bei Ihrer schriftlichen Anfrage unbedingt Ihre Telefonnummer an, unter der Sie tagsüber erreichbar sind, damit wir Ihr Anliegen schnellstmöglich bearbeiten können.


Bestellen

TURNIER-AKTUELL existiert in zwei Versionen:

  • Die Light Edition enthält nur die Softwarekomponenten Turnierplanung und Turnierleitung. Diese Version ist die kostengünstige Alternative für alle, die auf den Turnier-Informationsdienst verzichten wollen.
  • Die Vollversion enthält die Softwarekomponenten Turnierplanung, Turnierleitung und Turnier-Informationsdienst.

Auf unserer Produkt-Homepage www.turnier-aktuell.de finden Sie das aktuelle Bestellformular als PDF-Datei. Zum Öffnen und Ausdrucken des Bestellformulars benötigen Sie das kostenlose Programm Acrobat Reader. Falls Sie dieses Programm noch nicht auf Ihrem System installiert haben, können Sie es sich direkt von Adobe Systems Incorporated* besorgen. Mit dem Acrobat Reader ab Version 5 können Sie das Bestellformular sogar online ausfüllen und anschließend drucken. Schicken Sie uns das ausgefüllte Bestellformular per Fax oder per Post. Unsere Faxnummer und Postanschrift finden Sie auf dem Bestellformular.
*

Da sich der Inhalt externer Webseiten – auch solche, auf die wir verweisen – ohne unsere Kenntnis und ohne unseren Einfluss jederzeit ändern kann, distanzieren wir uns ausdrücklich von allen externen Seiten, zu denen ein Verweis (Link) gesetzt ist. Wir sind nicht verantwortlich für den Inhalt externer Links. Für den Inhalt verlinkter Seiten ist ausschließlich der Betreiber dieser Seiten verantwortlich.

Bei der Installation fremder Software-Produkte wird bezüglich der Bestätigung der Lizenzvereinbarungen darauf hingewiesen, diese sorgfältig zu lesen und auch zur Kenntnis zu nehmen.